Help!! Rent-To-Own Issues

Started by DavidPriamos-splice

DavidPriamos-splice

I already paid my first payment on the rent to own  thing and it said that I needed a Serial # (that I never got) so I can't access Serum. Then I tried to delete everything (the Serum .dlls) and then I did the whole process again and it said the license that I has was invalid. How do I fix this?

Thanks for writing in, and sorry for any issues! 
When using Splice RTO, you should not be asked for a product key for Serum.  
Usually this means you had previously installed a copy Serum on the computer.  Quite literally either you are loading an older Serum version, or Splice never deposited a license on your computer (e.g. update Splice).

First, here's boilerplate message from Splice (and me I guess now!):


Please make sure you have deleted any previous versions of Serum you have on your computer. Then confirm that you are signed into the Splice app (the Splice logo will appear in your menubar) and have the latest version of the Splice client installed. The current version for OSX is 2.1, and for Windows it's 1.2.15. If you need to download the Splice app, you can do so here: splice.com/download

If you need to re-install Serum, open the client and navigate to the 'Plugins' Tab and click 'Reinstall'

You can also download the Serum installer here: https://splice.com/plugins/install/serum

and if problems persist:

on Windows, try deleting the Serum folder in  C:\%APPDATA%\Xfer 

or on OSX:
1) 
command-shift-G and type or paste paste: 
~/Library/Application Support/com.xferrecords.serum 
delete User.dat 

2) 
command-shift-G in Finder 
/Library/Audio/Presets/Xfer Records/Serum Presets/System/ 

right-click (ctrl-click) User.dat -> open with .. (other) TextEdit 

select all text, delete, type something short e.g. ABCD, save 

Serum should not ask for you SN# next run (or else there is no Splice license file, and you should again make sure you're using the latest Splice client and that it shows Serum as leased).

Warm regards, 
Steve

DavidPriamos-splice

I tried everything you told me to do and it did not work. I need to get this fixed fast. Please help.

NippyTippers-splice

I have been paying for Serum for months now and I've never had any problems but just today I encountered an error when I opened Serum. On the top portion of Serum it displays a message saying "Sorry your license has expired." when I know it hasn't. Any idea what's going on? I checked to see if the Splice website showed Serum as active for me and it has. I don't know what else to do. Thanks for help in advance.

DavidPriamos-splice

It did this to me once and i know some solutions.

  1. Restart your whole computer.
    2.Make sure internet connection is stable
  2. Make sure serum is payed.
  3. Make sure the splice client is running and logged in.

steve_xfer

Those are all good suggestions.  Serum just reads a temporary license file deposited from the Splice client.  If you stop running the Splice client, or don't log in to Splice on it, the license file will become old and expire.   Keep in mind you need to be logged in (internet-connected) with Splice client once every three days.  This tends to work fine with zero thought, if you leave the Splice client running.   If you are still stuck after trying the above, use the contact form and mention your OS.

analoguemarty-splice

I've experienced the same issue as the above users. It's especially frustrating at gigs when I wanna use my custom patches and they won't load due to the license issue. If I pay the remaining balance on my plan, will Serum still verify the Splice license file?

steve_xfer

When Serum is paid for in full, no internet connection is needed. The Splice license file can get deleted at will at that point (which it should automatically by the Splice client if you pay it off via Splice).

Ya whenever my cpu updated the serum plugin doesnt even show up in the splice app now so im probably gonna need suggestions

Luigisanchezdj

I was using the rent to buy version of Serum. I just decided to buy it, so I downloaded from my account but now I want to enter my serial code but the Plugin is still linked to The Splice account. I have tried to uninstall The App and install once again. Nothing has worked.

ZIAX-splice

Hi, i also bought it from the site and am currently experiencing the same issue… > Splice licence expired, any solution yet?

steve_xfer

Please use the contact form for assistance with license issues.