Serum licensing issues for serums rent-to-own?

Started by drakesundin1

drakesundin1

Hello,

I am currently using the splice rent to own for serum, and I've reinstalled and reopened serum several times, but I still get the same message asking me to enter my serial code or to go into the splice app (then lists the stuff I already tried). How can I use serum again? I love the plugin, and I thank Steve for being such a genius.

steve_xfer

Hi,

Thanks for the nice words.
Try signing out and back in to the Splice app. Longer message follows.

When using Splice RTO, you should not be asked for a product key for Serum.

Since you are, this means one of just a few possibilities:

  • you had previously installed an old copy Serum on the computer and it is (now) running
  • Splice has not deposited a license on your computer (e.g. download / update Splice app and log in) <- very likely if "new computer"
  • Splice has revoked a license from a failed payment (?) <- very likely if it worked prior…

Keep in mind you need to be connected to Splice app online at least once every 3 days. Once you have paid off Serum this is no longer needed.

Please use the contact form and mention OS if you are still stuck.

Warm regards,
Steve