Update Serum ?

Started by Kjeand2


I'm having trouble accessing presets called Jack-U for Serum. I purchased these presets from ADSR. I downloaded them to my downloads folder initially and then got a pop up saying I needed the latest update for Serum to use these presets so I updated Serum to 1.09.
Now the presets won't load because they're evidently in the wrong folder.
Can someone please help me to get these presets into the correct folder?
I tried to include a screenshot here but couldn't but this is what the pop up message says.
Library/Audio/Presets/Xfer Records/Serum Presets/NoisesUser/MelbVox2 C2.wav.
Please help
Thanks in advance,
Robert Williams

It looks like they need custom noise sounds as well, did you receive two folders, one with noises? I would recommend contacting ADSR since they provided you the presets. 

I just purchased Serum FX. this is the newest version of serum correct? it hasn't asked me for my serial number and only loads the effects to the preset pack i got from cymatics which i read that it maybe because i don't have the wave tables. but yes im so confused

i also downloaded the beta and recanned plugins and only the 1.07 appears

I figured it out! jsut had to remove the old pkg. > close ableton > re-open > rescan

Hi Steve, I downloaded the update and deleted the initial version vst and component but when open new presets it says I need to make an update. Ableton and Mac is what i use.
Its really frustrating cause i wanna try this presets.
Thanks in advance.


Look on Build on the global tab for what version it says there.


where can I download the latest version of serum.  Having an issue loading my new preset pack and figure the problem is because I'm running 1.0. I dont connect my studio to the internet. So I cant run it right through. Have to get it outside the program somehow.


That's the version to use, quit your host/DAW if you aren't already.  Most often it's from  installing to a different location.  Try manually removing the old Serum.dll / Serum_x64.dll assuming you know where the DAW is looking for VST plugins.

I Installed V1.00 which ran ok, then when I updated to 109b6 and try to load VST it crashes Live 9.6.
I've tried removing everything and clean installing after a restart with the same outcome.

Any help would be great! 


Hi Steve, I just purchased Serum. how can I tell if I have the latest version? If I click on "Menu" and "About.." In the upper right corner of the auto-scrolling page, is says Version 1.000. Am I correct to assume that this is not the latest version?


Hi taconight2night, thanks for the purchase.  Quit your host and run the latest update installer (middle download) in "your account".  If you still see 1.00 on Build on the Global tab, then manual removal of the plugin will do it, let me know your host and OS if you need help locating the 1.0 plugin.


Hi Steve thanks for the reply. I am using FL Studio 12 and I have Windows 7 on my computer. I have installed the 1.000 version and it is working great but after downloading the update file, my computer will not open the file. I am assuming that I need to open the downloaded file to "run the update"? When I try to open it, my computer tells me something along the lines of "Windows can not open this file, to open this file Windows needs to know what program you want to use…" It then tries to get me to download Bitzip or something similar. I hope this all makes sense and that you can help. I've been trying all afternoon :(


Make sure you are downloading the update (middle download) not the FX version update.  It should end .exe - if it does not you could try adding .exe to the filename, but I'd recommend to try downloading it first.


Hi Steve, I got it to work by downloading the demo version first and then updating it. For some reason it wouldn't let me update if I downloaded the non-demo 1.000 version. Thanks again for the help and speedy replies, great customer service!

ive just installed serum, all fine loaded in my daw and its asking for me to locate the preset folder, i did not see a download link for the preset folder nor has it appeared in my pluggins destination folder where serum is installed. 
how can i get the presets i need for serum to work?


Hi mc1echo, You need to first install the v1.0, (lowest download in your account) then re-run the update installer.


I want to try our a preset pack and ive tried updating but everytime i open a preset, it says that the preset was made with a newer version of serum!! I bought the vst legitimately 


You're probably still using an old version, e.g. installing the plugin to a different location. verify the build on Global tab, email me or use the Serum forum for further support.


Hey Steve! On the global tab it says that I have build 1.079 and im pretty sure thats not the most updated version + the date is December 9th 2015. I downloaded serum again but nothing is changing.


manually remove the old plugin file.  If you don't know where this is located please contact me (contact form) with your DAW and OS.

Ok I am having the same issue but on mac. Do i need to uninstall serum completely then reinstall with the update? also if i do that will i loose/have to re-install my preset packs?

Hi Steve. Ok I am having the same issue but on mac. Do i need to uninstall serum completely then reinstall with the update? also if i do that will i loose/have to re-install my preset packs?